Backtrack 5 KDE startx Failed To Load Error and Solution

by on June 5, 2011 · 27 comments· LAST UPDATED June 5, 2011

in

I've downloaded Backtrack Linux version 5 KDE desktop 64 bit. To start a graphical interface I' typed startx command. But it failed with the following error message:

BackTrack Linux 5 64bits Vmware Workstation Installation

BackTrack Linux 5 64bits Vmware Workstation Installation

How do I fix this problem and install Backtrack Linux version 5 KDE desktop on my hard disk?

Backtrack Linux is a penetration testing and security auditing Linux distribution. You can run it from Live CD or install it on the hard disk. This is well known bug[1] in Backtrack Linux v5 KDE 64 bit. To fix this problem cd to /root/.kde/ and delete *.kcache files in the following directories:

[a] /root/.kde/cache-bt

[b] /root/.kde/cache-root

Type the following find commands to find and delete .kcache files:
# cd /root/.kde/
# find . -type f -iname "*.kcache" -delete

Type the following command to start KDE desktop:
# startx

Backtrack 5 KDE Linux Deskop Screenshot

Backtrack 5 KDE Linux Deskop Screenshot


To install click on "Install Backtrack" icon.

References:

  1. Bug # 23 - startx does not work in KDE 64bit.
TwitterFacebookGoogle+PDF versionFound an error/typo on this page? Help us!

{ 27 comments… read them below or add one }

1 Daveonator June 6, 2011 at 2:37 am

Same thing happened to me but I got it to work, check this out.

Reply

2 Jerime June 11, 2011 at 8:21 am

this work perfect, been searching the net whole day for this

Reply

3 pravin June 13, 2011 at 10:59 am

this worked perfectly for me… thank you..

Reply

4 Vinicius June 13, 2011 at 9:28 pm

Very good…works fine

Reply

5 Tony June 25, 2011 at 10:05 pm

Works for me, but it’s only a partial solution. The kcache files are re-created with every shutdown/start and have to be deleted again. The cache files also seem to be related to “remembering” desktop settings because I’m prompted for the same soundcard issue every time. If no proper fix is forthcoming I’m switching to the Gnome desktop.

Reply

6 SoQoR July 12, 2011 at 6:05 am

Hello
I got the same problem with me and the system device 32 bt not 64 oky
what can i do to fix thes proplem

Please note that I carried out these orders did not work

help me plz

Reply

7 damn July 15, 2011 at 7:10 pm

works perfectly, thanks brah!

Reply

8 Drago July 26, 2011 at 7:52 pm

any solution for gnome? i have this problem but in gnome

Reply

9 Mikopet July 28, 2011 at 2:36 pm

Great Job!

Reply

10 Hiruna August 24, 2011 at 7:31 am

Thanks :) this really helped me..

Reply

11 bhathi September 20, 2011 at 3:39 pm

THANX MAN LOVE UUU ~!!

Reply

12 Indra Saputra Ahmadi November 14, 2011 at 12:52 pm

it doesn’t work in backtrack 5 kde 32 bit…

Reply

13 Pablo November 18, 2011 at 5:11 pm

Thanks for this fix, worked great!

Reply

14 Sooo102 November 18, 2011 at 8:22 pm

Thank You, Well Done !!

Reply

15 Arne-per March 26, 2012 at 2:50 pm

How do you type the symbol [ " ]?

Reply

16 mimo April 22, 2012 at 5:47 pm

somebody help me , how can i unlock backtrack

Reply

17 Sumit May 18, 2012 at 5:37 pm

Please Somebody Help To Figure Me out of this Situation.
i am using command “apt-get install metasploit”.
but it is not working in Social Engg. Kit,
and Other Problem is that am not abel to do it
it show me
err> not abel to fetch from repositry.back-track.com something like that plz solve

Reply

18 rmn June 9, 2012 at 9:18 am

thank you sooooooooooooooooooooooooooooooooooo much

Reply

19 No.1 fan August 19, 2012 at 6:33 pm

thanks man it s now working

Reply

20 Bilal September 18, 2012 at 7:49 am

Hi, I’m a new BT user and just downloaded and installed BT5 in a pendrive.
I solved some issues i had with the booting process, and another problem i had with the startx (only the first letter lighted up and no GUI loaded, bringing me back to the command screen)
to solve that last problem I followed the instructions given by you and I could load all the asian letters and that stuff.

Now, the problem is that when it finish the loading part a black screen appears and 3 error messages pop up:
-Kwin closed unexpectedly Kwin PID:2816
-Kmix closed unexpectedly Kmix PID: 2868
-Run command interface closed unexpectedly Krunner PID:2862

After a few secconds the last one starts poping up repeatedly changing the PID each time.
I can’t send a bug report because i don’t have any debuger installed nor can install any: the only thing I can do is close the error messages and look at the black screen.

Can somebody help me please? I’ve been looking arround in this and other forums but found nothing yet =/
Thanks

Reply

21 André October 21, 2012 at 4:35 am

Thank’s man…

Reply

22 Muneeb Ahsan October 28, 2012 at 6:47 pm

this is not work for me… how it can be fix or tell me this bug not removed officially????

Reply

23 vinicius December 1, 2012 at 7:06 pm

and gnome???
please help-me with this problem.

Reply

24 conrad March 14, 2013 at 8:17 pm

Thanks a bunch. :)

Reply

25 bed September 5, 2013 at 5:07 pm

that’s great thank you

Reply

26 Gaurav February 18, 2014 at 1:55 pm

thanks a bunch dude.. it helped me alot

Reply

27 maha March 20, 2014 at 8:37 pm

i have worked on backtrack 5 bt on this facebook messages can not be open it gives empty page plz tell me solution

Reply

Leave a Comment

Tagged as: , , , , , , , , ,

Previous Faq:

Next Faq: