≡ Menu

Backtrack 5 KDE startx Failed To Load Error and Solution

I've downloaded Backtrack Linux version 5 KDE desktop 64 bit. To start a graphical interface I' typed startx command. But it failed with the following error message:

BackTrack Linux 5 64bits Vmware Workstation Installation

BackTrack Linux 5 64bits Vmware Workstation Installation

How do I fix this problem and install Backtrack Linux version 5 KDE desktop on my hard disk?

Backtrack Linux is a penetration testing and security auditing Linux distribution. You can run it from Live CD or install it on the hard disk. This is well known bug[1] in Backtrack Linux v5 KDE 64 bit. To fix this problem cd to /root/.kde/ and delete *.kcache files in the following directories:

[a] /root/.kde/cache-bt

[b] /root/.kde/cache-root

Type the following find commands to find and delete .kcache files:
# cd /root/.kde/
# find . -type f -iname "*.kcache" -delete

Type the following command to start KDE desktop:
# startx

Backtrack 5 KDE Linux Deskop Screenshot

Backtrack 5 KDE Linux Deskop Screenshot


To install click on "Install Backtrack" icon.

References:

  1. Bug # 23 - startx does not work in KDE 64bit.
Tweet itFacebook itGoogle+ itPDF itFound an error/typo on this page?

{ 27 comments… add one }

  • Daveonator June 6, 2011, 2:37 am

    Same thing happened to me but I got it to work, check this out.

  • Jerime June 11, 2011, 8:21 am

    this work perfect, been searching the net whole day for this

  • pravin June 13, 2011, 10:59 am

    this worked perfectly for me… thank you..

  • Vinicius June 13, 2011, 9:28 pm

    Very good…works fine

  • Tony June 25, 2011, 10:05 pm

    Works for me, but it’s only a partial solution. The kcache files are re-created with every shutdown/start and have to be deleted again. The cache files also seem to be related to “remembering” desktop settings because I’m prompted for the same soundcard issue every time. If no proper fix is forthcoming I’m switching to the Gnome desktop.

  • SoQoR July 12, 2011, 6:05 am

    Hello
    I got the same problem with me and the system device 32 bt not 64 oky
    what can i do to fix thes proplem

    Please note that I carried out these orders did not work

    help me plz

  • damn July 15, 2011, 7:10 pm

    works perfectly, thanks brah!

  • Drago July 26, 2011, 7:52 pm

    any solution for gnome? i have this problem but in gnome

  • Mikopet July 28, 2011, 2:36 pm

    Great Job!

  • Hiruna August 24, 2011, 7:31 am

    Thanks :) this really helped me..

  • bhathi September 20, 2011, 3:39 pm

    THANX MAN LOVE UUU ~!!

  • Indra Saputra Ahmadi November 14, 2011, 12:52 pm

    it doesn’t work in backtrack 5 kde 32 bit…

  • Pablo November 18, 2011, 5:11 pm

    Thanks for this fix, worked great!

  • Sooo102 November 18, 2011, 8:22 pm

    Thank You, Well Done !!

  • Arne-per March 26, 2012, 2:50 pm

    How do you type the symbol [ ” ]?

  • mimo April 22, 2012, 5:47 pm

    somebody help me , how can i unlock backtrack

  • Sumit May 18, 2012, 5:37 pm

    Please Somebody Help To Figure Me out of this Situation.
    i am using command “apt-get install metasploit”.
    but it is not working in Social Engg. Kit,
    and Other Problem is that am not abel to do it
    it show me
    err> not abel to fetch from repositry.back-track.com something like that plz solve

  • rmn June 9, 2012, 9:18 am

    thank you sooooooooooooooooooooooooooooooooooo much

  • No.1 fan August 19, 2012, 6:33 pm

    thanks man it s now working

  • Bilal September 18, 2012, 7:49 am

    Hi, I’m a new BT user and just downloaded and installed BT5 in a pendrive.
    I solved some issues i had with the booting process, and another problem i had with the startx (only the first letter lighted up and no GUI loaded, bringing me back to the command screen)
    to solve that last problem I followed the instructions given by you and I could load all the asian letters and that stuff.

    Now, the problem is that when it finish the loading part a black screen appears and 3 error messages pop up:
    -Kwin closed unexpectedly Kwin PID:2816
    -Kmix closed unexpectedly Kmix PID: 2868
    -Run command interface closed unexpectedly Krunner PID:2862

    After a few secconds the last one starts poping up repeatedly changing the PID each time.
    I can’t send a bug report because i don’t have any debuger installed nor can install any: the only thing I can do is close the error messages and look at the black screen.

    Can somebody help me please? I’ve been looking arround in this and other forums but found nothing yet =/
    Thanks

  • André October 21, 2012, 4:35 am

    Thank’s man…

  • Muneeb Ahsan October 28, 2012, 6:47 pm

    this is not work for me… how it can be fix or tell me this bug not removed officially????

  • vinicius December 1, 2012, 7:06 pm

    and gnome???
    please help-me with this problem.

  • conrad March 14, 2013, 8:17 pm

    Thanks a bunch. :)

  • bed September 5, 2013, 5:07 pm

    that’s great thank you

  • Gaurav February 18, 2014, 1:55 pm

    thanks a bunch dude.. it helped me alot

  • maha March 20, 2014, 8:37 pm

    i have worked on backtrack 5 bt on this facebook messages can not be open it gives empty page plz tell me solution

Leave a Comment