≡ Menu

How do I find what dependencies a rpm file has?

RPM is a Package Manager for popular distribution such as Red Hat, Suse and many others. It is a powerful command line package management system for installing uninstalling, verifying, querying, and updating Linux computer software packages.

You can finding out what dependencies a rpm file has i.e. it will tell you what you need to install package with following command:
rpm -qpR {.rpm-file}
rpm -qR {package-name}

Find out what dependencies a uninstalled rpm file called mediawiki-1.4rc1-4.i586.rpm:
# rpm -qpR mediawiki-1.4rc1-4.i586.rpm

It will print list of dependencies on screen (output):

mod_php
php-session
php-gettext
php-zlib
php-mysql
ImageMagick-Magick++
tetex
cjk-latex
rpmlib(PayloadFilesHavePrefix)

However RPM has in build mechanism to tell you about dependencies. Just try to install package and it will give you list of dependencies.
# rpm -ivh mediawiki-1.4rc1-4.i586.rpm

Output:

error: Failed dependencies:
   mod_php is needed by mediawiki-1.4rc1-4
   php-session is needed by mediawiki-1.4rc1-4
   php-gettext is needed by mediawiki-1.4rc1-4
   php-zlib is needed by mediawiki-1.4rc1-4
   php-mysql is needed by mediawiki-1.4rc1-4
   ImageMagick-Magick++ is needed by mediawiki-1.4rc1-4
   tetex is needed by mediawiki-1.4rc1-4
   cjk-latex is needed by mediawiki-1.4rc1-4

Note:

  • .rpm file: File with .RPM extension. Typically this file is not installed. It may be on CD or you just downloaded from Internet.
  • package-name: It is installed RPM file.

You can solve dependencies problem by installing each individual package(s). If you are using Red hat Linux then you can try this tip. If you are using Fedora core Linux then try yum. If you are using Suse linux then use Yast to install rpms.

Tweet itFacebook itGoogle+ itPDF itFound an error/typo on this page?

{ 4 comments… add one }

  • Hanh Nguyen July 31, 2007, 10:34 am

    First thanks for help ,i can’t install Python 2.3.4-2.aix5.1.ppc.rpm without error dependencies libcrypto.a,libgdbm.a,libssl.a ;
    any experiences in installing “AIX rpms” for this inconvenient? with –nodeps ???

  • Arshad March 6, 2011, 7:17 pm

    Hello,

    I am not able to figure out what is going wrong here…can you guys..have a look..and give me feedback why these packages are not getting installed…

    I want…to install
    elfutils-libelf-devel-0.137-3.el5.i386.rpm
    elfutils-libelf-devel-static-0.137-3.el5.i386.rpm

    Rhel 5.4

    please help!!
    ========================================================

    [root@applications Server]# rpm -Uvh elfutils-libelf-devel-static-0.137-3.el5.i386.rpm
    error: Failed dependencies:
    elfutils-libelf-devel-i386 = 0.137-3.el5 is needed by elfutils-libelf-devel-static-0.137-3.el5.i386
    [root@applications Server]# rpm -Uvh elfutils-libelf-devel-0.137-3.el5.i386.rpm
    error: Failed dependencies:
    elfutils-libelf-devel-static-i386 = 0.137-3.el5 is needed by elfutils-libelf-devel-0.137-3.el5.i386
    [root@applications Server]# rpm -qpR elfutils-libelf-devel-static-0.137-3.el5.i386.rpm
    elfutils-libelf-devel-i386 = 0.137-3.el5
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(VersionedDependencies) <= 3.0.3-1
    [root@applications Server]# rpm -qpR elfutils-libelf-devel-0.137-3.el5.i386.rpm
    elfutils-libelf-devel-static-i386 = 0.137-3.el5
    elfutils-libelf-i386 = 0.137-3.el5
    libelf.so.1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(VersionedDependencies) <= 3.0.3-1
    [root@applications Server]# apt-get install elfutils
    -bash: apt-get: command not found
    [root@applications Server]# rpm -aq|grep elfutils-libelf
    elfutils-libelf-0.137-3.el5
    [root@applications Server]#

    Thanks…

    • Raj February 23, 2015, 8:16 am
      # rpm -Uvh --repackage --nodeps elfutils-libelf-devel-static-0.137-3.el5.i386.rpm --test
      # rpm -Uvh --repackage --nodeps elfutils-libelf-devel-static-0.137-3.el5.i386.rpm
  • Aymen April 14, 2014, 9:12 pm

    hi ..
    I am trying to install oracle developer 6i on Linux 5 it’s my first time, found problem to install rpm ,
    had enough try with nothing , pls, could help me by steps i really need it.
    God bless all

Leave a Comment