Lighttpd checking for GTHREAD… configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met error and solution

by on April 1, 2007 · 2 comments· LAST UPDATED April 1, 2007

in , ,

Q. I’m trying to install lighttpd 1.5.0 while compiling source code I’m getting an error which read as follows:

checking for GTHREAD... configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met:

No package 'gthread-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTHREAD_CFLAGS
and GTHREAD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

How do I fix this issue; I'm using Fedora Core 6.x.

A. You need to install a package called glib2-devel. Lighttpd 1.5.x+ requires glib2-2.4.0 or higher.

Type the following command if you are using Redhat (RHEL) or Fedora Core or Cent OS:
# yum install glib2-devel

If you are using Debian/Ubuntu try following command:
# apt-get install libglib2.0-dev
$ sudo apt-get install libglib2.0-dev

Now compile and install lighttpd:
# ./configure;make;make install

Tweet itFacebook itG+ itDownload PDF versionFound an error/typo on this page?

{ 2 comments… read them below or add one }

1 ende November 17, 2007 at 4:59 pm

thanks man


2 van March 25, 2011 at 7:56 am

so useful post. thanks you so much


Leave a Comment

Tagged as:

Previous Faq:

Next Faq: