firefox extensions

My Debian Linux 6 (64 bit) has Epiphany installed which is the GNOME web browser. Epiphany aims to be simple to use and standards compliant but I want all other Firefox extensions. How do I install the latest version of Firefox 4 under Debian Linux version 6?

{ 4 comments }