≡ Menu

rc1

FreeBSD 7.2RC Released

The second of two planned Release Candidates for the FreeBSD 7.2-RELEASE cycle is now available. ISO images for Tier-1 architectures are now available on most of the FreeBSD mirror sites.

The freebsd-update(8) utility supports binary upgrades of i386 and amd64
systems running earlier FreeBSD releases. Systems running 7.0-RELEASE,
7.1-RELEASE, 7.2-BETA1, or 7.2-RC1 can upgrade as follows:

# freebsd-update upgrade -r 7.2-RC2

During this process, FreeBSD Update may ask the user to help by merging
some configuration files or by confirming that the automatically performed
merging was done correctly.

# freebsd-update install

The system must be rebooted with the newly installed kernel before continuing.
# shutdown -r now

After rebooting, freebsd-update needs to be run again to install the new
userland components, and the system needs to be rebooted again:

# freebsd-update install
# shutdown -r now

Download Firefox 3 Release Candidate 1

Firefox 3 release candidate 1 (RC1) is available for download from official project web site. Firefox 3 is based upon Gecko 1.9 engine, which has more than 14,000 updates including some major re-architecting to provide improved performance, stability, rendering correctness, and code simplification and sustainability. Firefox 3 has been built on top of this new platform resulting in a more secure, easier to use, more personal product with a lot more under the hood to offer website and Firefox add-on developers.

Quick Firefox 3 RC1 Installation

Type the following command at a shell prompt:
$ cd /tmp && wget 'http://download.mozilla.org/?product=firefox-3.0rc1&os=linux&lang=en-US'
$ tar -jxvf firefox-3.0rc1.tar.bz2

Backup existing settings:
$ mkdir ~/backup
$ cp -avr ~/.mozilla/ ~/backup/

Now install new firefox at /opt:
$ sudo tar -jxvf firefox-3.0rc1.tar.bz2 -C /opt/
Start Firefox:
$ /opt/firefox/firefox &

firefox-3-screen-shot
(Fig.01: Firefox 3 in action [click to enlarge image])

Download FireFox 3 RC1 for Windows / Linux / OS X

A word about addons

Following addons are not compatible with FF3:

  • Firebug (beta version should work with FF3, see comments below)
  • Yslow
  • Google toolbar
  • Stumble toolbar

Updated for accuracy!