Linux: warning: CUPSEXT could not be loaded. Please check HPLIP installation.

Posted on in Categories , last updated September 29, 2012

I‘m trying to install latest version of Hewlett-Packard’s Linux Imaging and Printing software (HPLIP) for my office jet printer. In order to install latest version of HPLIP I removed the hplip-gui, hplip, hplip-cups, hplip-data, hpijs, and hpijs-ppds Debian Linux packages However, I’m getting the following error:

Debian warning: CUPSEXT could not be loaded. Please check HPLIP installation.

How do I fix this error while installing hplip-3.12.9.run under Debian Linux 6.0.5 amd64 bit?


This is a well known problem as installer need cupsext.so file which is installed at /usr/lib/pymodules/python2.6/cupsext.so or /usr/lib/python2.6/dist-packages/cupsext.so location. This file is part of HPLIP package version 3.10.6 under Debian Linux v6.0.5 (squeeze stable). So to fix this problem install the following packages:
$ sudo apt-get install hplip-gui hplip hplip-cups hplip-data hpijs hpijs-ppds
Once installed run HPLIP installer:
$ bash hplip-3.12.9.run
Select automatic installation mode and when prompted as follows select overwrite

DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
HPLIP-3.10.6 exists, this may conflict with the new one being installed.
Do you want to ('i'= Remove and Install, 'o'= Overwrite*, 'q'= Quit)?	: o

This will overwrite existing HPLIP with the latest version.

References:

4 comment

  1. Thank you! Being new to Linux/Ubuntu, I’m finding these sites all the more helpful for solving these problems. Cheers!

Leave a Comment