Lighttpd checking for GTHREAD… configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met error and solution

Q. I’m trying to install lighttpd 1.5.0 while compiling source code I’m getting an error which read as follows:

ADVERTISEMENTS

checking for GTHREAD… configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met:

No package ‘gthread-2.0’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTHREAD_CFLAGS
and GTHREAD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

How do I fix this issue; I’m using Fedora Core 6.x.

A. You need to install a package called glib2-devel. Lighttpd 1.5.x+ requires glib2-2.4.0 or higher.

Type the following command if you are using Redhat (RHEL) or Fedora Core or Cent OS:
# yum install glib2-devel

If you are using Debian/Ubuntu try following command:
# apt-get install libglib2.0-dev
OR
$ sudo apt-get install libglib2.0-dev

Now compile and install lighttpd:
# ./configure;make;make install
=>

🐧 Get the latest tutorials on SysAdmin, Linux/Unix, Open Source/DevOps topics:
CategoryList of Unix and Linux commands
File Managementcat
FirewallCentOS 8 OpenSUSE RHEL 8 Ubuntu 16.04 Ubuntu 18.04 Ubuntu 20.04
Network Utilitiesdig host ip nmap
OpenVPNCentOS 7 CentOS 8 Debian 10 Debian 8/9 Ubuntu 18.04 Ubuntu 20.04
Package Managerapk apt
Processes Managementbg chroot cron disown fg jobs killall kill pidof pstree pwdx time
Searchinggrep whereis which
User Informationgroups id lastcomm last lid/libuser-lid logname members users whoami who w
WireGuard VPNCentOS 8 Debian 10 Firewall Ubuntu 20.04

ADVERTISEMENTS
2 comments… add one
  • ende Nov 17, 2007 @ 16:59

    thanks man

  • van Mar 25, 2011 @ 7:56

    so useful post. thanks you so much

Leave a Reply

Your email address will not be published.

Use HTML <pre>...</pre>, <code>...</code> and <kbd>...</kbd> for code samples.