Q. Iā€™m trying to install lighttpd 1.5.0 while compiling source code Iā€™m getting an error which read as follows:


checking for GTHREAD… configure: error: Package requirements (gthread-2.0 >= 2.4.0) were not met:

No package ‘gthread-2.0’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTHREAD_CFLAGS
and GTHREAD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

How do I fix this issue; I’m using Fedora Core 6.x.

A. You need to install a package called glib2-devel. Lighttpd 1.5.x+ requires glib2-2.4.0 or higher.

Type the following command if you are using Redhat (RHEL) or Fedora Core or Cent OS:
# yum install glib2-devel

If you are using Debian/Ubuntu try following command:
# apt-get install libglib2.0-dev
$ sudo apt-get install libglib2.0-dev

Now compile and install lighttpd:
# ./configure;make;make install

šŸ„ŗ Was this helpful? Please add a comment to show your appreciation or feedback.

nixCrat Tux Pixel Penguin
Hi! šŸ¤ 
I'm Vivek Gite, and I write about Linux, macOS, Unix, IT, programming, infosec, and open source. Subscribe to my RSS feed or email newsletter for updates.

2 comments… add one
  • ende Nov 17, 2007 @ 16:59

    thanks man

  • van Mar 25, 2011 @ 7:56

    so useful post. thanks you so much

Leave a Reply

Your email address will not be published. Required fields are marked *

Use HTML <pre>...</pre> for code samples. Your comment will appear only after approval by the site admin.