Ubuntu Linux 16.04 LTS list all upgradable packages apt command

Fig.02: Ubuntu Linux 16.04 LTS list all upgradable packages apt command

Fig.02: Ubuntu Linux 16.04 LTS list all upgradable packages apt command

To list and see all upgradable kernel updates, packages and security updates on Ubuntu Linux server, enter:
$ sudo apt update
$ apt list --upgradable

Sample outputs:

Listing... Done
apport/xenial,xenial 2.20.1-0ubuntu1 all [upgradable from: 2.20-0ubuntu3]
bsdutils/xenial 1:2.27.1-6ubuntu2 amd64 [upgradable from: 1:2.27.1-6ubuntu1]
dbus/xenial 1.10.6-1ubuntu3 amd64 [upgradable from: 1.10.6-1ubuntu2]
dmeventd/xenial 2:1.02.110-1ubuntu8 amd64 [upgradable from: 2:1.02.110-1ubuntu7]
dmsetup/xenial 2:1.02.110-1ubuntu8 amd64 [upgradable from: 2:1.02.110-1ubuntu7]
ethtool/xenial 1:4.5-1 amd64 [upgradable from: 1:4.2-1]
gcc-5-base/xenial 5.3.1-13ubuntu3 amd64 [upgradable from: 5.3.1-13ubuntu1]
geoip-database/xenial,xenial 20160317-1 all [upgradable from: 20160210-1]
grub-legacy-ec2/xenial,xenial 0.7.7~bzr1192-0ubuntu2 all [upgradable from: 0.7.7~bzr1189-0ubuntu1]
libblkid1/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
libdbus-1-3/xenial 1.10.6-1ubuntu3 amd64 [upgradable from: 1.10.6-1ubuntu2]
libdevmapper-event1.02.1/xenial 2:1.02.110-1ubuntu8 amd64 [upgradable from: 2:1.02.110-1ubuntu7]
libdevmapper1.02.1/xenial 2:1.02.110-1ubuntu8 amd64 [upgradable from: 2:1.02.110-1ubuntu7]
libfdisk1/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
libglib2.0-0/xenial 2.48.0-1ubuntu3 amd64 [upgradable from: 2.47.6-1]
libglib2.0-data/xenial,xenial 2.48.0-1ubuntu3 all [upgradable from: 2.47.6-1]
liblvm2cmd2.02/xenial 2.02.133-1ubuntu8 amd64 [upgradable from: 2.02.133-1ubuntu7]
liblxc1/xenial 2.0.0~rc15-0ubuntu1 amd64 [upgradable from: 2.0.0~rc13-0ubuntu2]
libmount1/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
libpam-cgfs/xenial 2.0.0-0ubuntu1 amd64 [upgradable from: 2.0.0~rc8-0ubuntu1]
libpam-systemd/xenial 229-3ubuntu2 amd64 [upgradable from: 229-3ubuntu1]
libpython3.5-minimal/xenial 3.5.1-10 amd64 [upgradable from: 3.5.1-9ubuntu1]
libpython3.5-stdlib/xenial 3.5.1-10 amd64 [upgradable from: 3.5.1-9ubuntu1]
librados2/xenial 10.0.5-0ubuntu1 amd64 [upgradable from: 10.0.3-0ubuntu1]
librbd1/xenial 10.0.5-0ubuntu1 amd64 [upgradable from: 10.0.3-0ubuntu1]
libsmartcols1/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
libstdc++6/xenial 5.3.1-13ubuntu3 amd64 [upgradable from: 5.3.1-13ubuntu1]
libsystemd0/xenial 229-3ubuntu2 amd64 [upgradable from: 229-3ubuntu1]
libudev1/xenial 229-3ubuntu2 amd64 [upgradable from: 229-3ubuntu1]
libuuid1/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
linux-generic/xenial 4.4.0.16.17 amd64 [upgradable from: 4.4.0.15.16]
linux-headers-generic/xenial 4.4.0.16.17 amd64 [upgradable from: 4.4.0.15.16]
linux-image-generic/xenial 4.4.0.16.17 amd64 [upgradable from: 4.4.0.15.16]
lvm2/xenial 2.02.133-1ubuntu8 amd64 [upgradable from: 2.02.133-1ubuntu7]
lxc/xenial,xenial 2.0.0~rc15-0ubuntu1 all [upgradable from: 2.0.0~rc13-0ubuntu2]
lxc-common/xenial 2.0.0~rc15-0ubuntu1 amd64 [upgradable from: 2.0.0~rc13-0ubuntu2]
lxc-templates/xenial 2.0.0~rc15-0ubuntu1 amd64 [upgradable from: 2.0.0~rc13-0ubuntu2]
lxc1/xenial 2.0.0~rc15-0ubuntu1 amd64 [upgradable from: 2.0.0~rc13-0ubuntu2]
lxcfs/xenial 2.0.0-0ubuntu1 amd64 [upgradable from: 2.0.0~rc8-0ubuntu1]
lxd/xenial 2.0.0~rc8-0ubuntu2 amd64 [upgradable from: 2.0.0~rc7-0ubuntu1]
lxd-client/xenial 2.0.0~rc8-0ubuntu2 amd64 [upgradable from: 2.0.0~rc7-0ubuntu1]
mount/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
openssh-client/xenial 1:7.2p2-2 amd64 [upgradable from: 1:7.2p2-1]
openssh-server/xenial 1:7.2p2-2 amd64 [upgradable from: 1:7.2p2-1]
openssh-sftp-server/xenial 1:7.2p2-2 amd64 [upgradable from: 1:7.2p2-1]
python3-apport/xenial,xenial 2.20.1-0ubuntu1 all [upgradable from: 2.20-0ubuntu3]
python3-lxc/xenial 2.0.0~rc15-0ubuntu1 amd64 [upgradable from: 2.0.0~rc13-0ubuntu2]
python3-problem-report/xenial,xenial 2.20.1-0ubuntu1 all [upgradable from: 2.20-0ubuntu3]
python3.5/xenial 3.5.1-10 amd64 [upgradable from: 3.5.1-9ubuntu1]
python3.5-minimal/xenial 3.5.1-10 amd64 [upgradable from: 3.5.1-9ubuntu1]
sudo/xenial 1.8.16-0ubuntu1 amd64 [upgradable from: 1.8.12-1ubuntu3]
systemd/xenial 229-3ubuntu2 amd64 [upgradable from: 229-3ubuntu1]
systemd-sysv/xenial 229-3ubuntu2 amd64 [upgradable from: 229-3ubuntu1]
tzdata/xenial,xenial 2016c-1 all [upgradable from: 2016c-0ubuntu1]
ubuntu-minimal/xenial 1.354 amd64 [upgradable from: 1.352]
ubuntu-standard/xenial 1.354 amd64 [upgradable from: 1.352]
udev/xenial 229-3ubuntu2 amd64 [upgradable from: 229-3ubuntu1]
util-linux/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]
uuid-runtime/xenial 2.27.1-6ubuntu2 amd64 [upgradable from: 2.27.1-6ubuntu1]

To install above listed updates, run:
$ sudo apt upgrade

Examples and usage: 19 Ubuntu / Debian Linux apt Command Examples